using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=some-html-stuff\>\n\s{7})([A-Za-z0-9]+)";
string input = @"<some-html-stuff>
sometext<more-html-stuff>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}