$re = '/(?<=some-html-stuff\>\n\s{7})([A-Za-z0-9]+)/';
$str = '<some-html-stuff>
sometext<more-html-stuff>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);