const regex = /(?<=some-html-stuff\>\n\s{7})([A-Za-z0-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=some-html-stuff\\>\\n\\s{7})([A-Za-z0-9]+)', '')
const str = `<some-html-stuff>
sometext<more-html-stuff>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}