re = /(?<=some-html-stuff\>\n\s{7})([A-Za-z0-9]+)/
str = '<some-html-stuff>
sometext<more-html-stuff>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end