# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a\b[^<>]*href=['"]?http[^<>]+)>/$1 target="_blank" alt="Regex examples sheet" title="Regex examples sheet">/gi;t' <<< "<a href=\"https://www.codebales.com/regex-expressions-a-working-sheet\" target=\"_blank\">Regex examples sheet</a>"