use strict;
my $str = '<a href="https://www.codebales.com/regex-expressions-a-working-sheet" target="_blank">Regex examples sheet</a>';
my $regex = qr/(<a\b[^<>]*href=['"]?http[^<>]+)>/ip;
my $subst = '$1 target="_blank" alt="Regex examples sheet" title="Regex examples sheet">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";