using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\b[^<>]*href=['""]?http[^<>]+)>";
string substitution = @"$1 target=""_blank"" alt=""Regex examples sheet"" title=""Regex examples sheet"">";
string input = @"<a href=""https://www.codebales.com/regex-expressions-a-working-sheet"" target=""_blank"">Regex examples sheet</a>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}