import Foundation
let pattern = #"(<a\b[^<>]*href=['"]?http[^<>]+)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<a href="https://www.codebales.com/regex-expressions-a-working-sheet" target="_blank">Regex examples sheet</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 target="_blank" alt="Regex examples sheet" title="Regex examples sheet">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)