package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)during.*\(\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\",.*\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\"\)|during.*\(startOfMonth\(\),.*now\(\)\)`)
var str = `project = SWB AND status changed from "In Regression" to (Done) during("2022-09-01", "2022-09-30")
project = SWB AND status changed from "In Regression" to (Done) during (startOfMonth(), now())
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}