import re
regex = re.compile(r"during.*\(\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\",.*\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\"\)|during.*\(startOfMonth\(\),.*now\(\)\)", flags=re.MULTILINE)
test_str = ("project = SWB AND status changed from \"In Regression\" to (Done) during(\"2022-09-01\", \"2022-09-30\")\n\n"
"project = SWB AND status changed from \"In Regression\" to (Done) during (startOfMonth(), now())\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")