import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "during.*\\(\\\"\\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\\\",.*\\\"\\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\\\"\\)|during.*\\(startOfMonth\\(\\),.*now\\(\\)\\)";
final String string = "project = SWB AND status changed from \"In Regression\" to (Done) during(\"2022-09-01\", \"2022-09-30\")\n\n"
+ "project = SWB AND status changed from \"In Regression\" to (Done) during (startOfMonth(), now())\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}