const regex = new RegExp('during.*\\(\\"\\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\\",.*\\"\\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\\"\\)|during.*\\(startOfMonth\\(\\),.*now\\(\\)\\)', 'gm')
const str = `project = SWB AND status changed from "In Regression" to (Done) during("2022-09-01", "2022-09-30")
project = SWB AND status changed from "In Regression" to (Done) during (startOfMonth(), now())
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}