$re = '`during.*\(\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\",.*\"\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])\"\)|during.*\(startOfMonth\(\),.*now\(\)\)`m';
$str = 'project = SWB AND status changed from "In Regression" to (Done) during("2022-09-01", "2022-09-30")
project = SWB AND status changed from "In Regression" to (Done) during (startOfMonth(), now())
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);