use strict;
my $str = '200.99.99.25
(([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))
([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|';
my $regex = qr/((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}