// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))").unwrap();
let string = "200.99.99.25
(([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))
([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}