$re = '/((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))/m';
$str = '200.99.99.25
(([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))
([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);