import Foundation
let pattern = #"((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))[.]((25[0-5])|(2[0-4][0-9])|(1[0-9][0-9])|([1-9][0-9])|([0-9]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
200.99.99.25
(([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))[.](([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|(2[5][1-5]))
([0-9])|([1-9][0-9])|(1[0-9][0-9])|(2[0-5][0])|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}