#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/)?(www\.youtu(\.be|be\.com)?\/(watch|shorts|)[\w-]{1,32})"
Local $sString = "https://www.youtube.com/watch" & @CRLF & _
"https://www.youtu.be/watch" & @CRLF & _
"https://www.youtube.com/shorts" & @CRLF & _
"https://www.youtu.be/shorts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")