re = /(https?:\/\/)?(www\.youtu(\.be|be\.com)?\/(watch|shorts|)[\w-]{1,32})/m
str = 'https://www.youtube.com/watch
https://www.youtu.be/watch
https://www.youtube.com/shorts
https://www.youtu.be/shorts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end