use strict;
my $str = 'https://www.youtube.com/watch
https://www.youtu.be/watch
https://www.youtube.com/shorts
https://www.youtu.be/shorts';
my $regex = qr/(https?:\/\/)?(www\.youtu(\.be|be\.com)?\/(watch|shorts|)[\w-]{1,32})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}