const regex = /(https?:\/\/)?(www\.youtu(\.be|be\.com)?\/(watch|shorts|)[\w-]{1,32})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www\\.youtu(\\.be|be\\.com)?\\\/(watch|shorts|)[\\w-]{1,32})', 'gm')
const str = `https://www.youtube.com/watch
https://www.youtu.be/watch
https://www.youtube.com/shorts
https://www.youtu.be/shorts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}