$re = '/(https?:\/\/)?(www\.youtu(\.be|be\.com)?\/(watch|shorts|)[\w-]{1,32})/m';
$str = 'https://www.youtube.com/watch
https://www.youtu.be/watch
https://www.youtube.com/shorts
https://www.youtu.be/shorts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);