import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^#\\n]+\\n#[\\w ]+?\\n[^\\n]+(?:\\n|$))|^([^\\n]+\\n)";
final String string = "The quick \n"
+ "#a comment\n"
+ "brown \n"
+ "fox jumps \n"
+ "#another comment\n"
+ "over \n"
+ "the \n"
+ "lazy\n"
+ "#yet another comment\n"
+ "dog";
final String subst = "#auto comment\\n$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}