import re
regex = re.compile(r"([^#\n]+\n#[\w ]+?\n[^\n]+(?:\n|$))|^([^\n]+\n)", flags=re.MULTILINE)
test_str = ("The quick \n"
"#a comment\n"
"brown \n"
"fox jumps \n"
"#another comment\n"
"over \n"
"the \n"
"lazy\n"
"#yet another comment\n"
"dog")
subst = "#auto comment\\n$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)