import Foundation
let pattern = ##"([^#\n]+\n#[\w ]+?\n[^\n]+(?:\n|$))|^([^\n]+\n)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
The quick
#a comment
brown
fox jumps
#another comment
over
the
lazy
#yet another comment
dog
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#auto comment\n$1$2"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)