// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^#\n]+\n#[\w ]+?\n[^\n]+(?:\n|$))|^([^\n]+\n)").unwrap();
let string = "The quick
#a comment
brown
fox jumps
#another comment
over
the
lazy
#yet another comment
dog";
let substitution = "#auto comment\\n$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}