$re = '/([^#\n]+\n#[\w ]+?\n[^\n]+(?:\n|$))|^([^\n]+\n)/m';
$str = 'The quick
#a comment
brown
fox jumps
#another comment
over
the
lazy
#yet another comment
dog';
$subst = "#auto comment\n$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;