#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(^|\n)OPEN\(\n,*[^\n]*\n[^)]*\) *CLOSE"
Local $sString = "OPEN(" & @CRLF & _
",a" & @CRLF & _
",b" & @CRLF & _
") CLOSE" & @CRLF & _
"OPEN(" & @CRLF & _
"c" & @CRLF & _
") CLOSE" & @CRLF & _
"OPEN(" & @CRLF & _
",d" & @CRLF & _
",e" & @CRLF & _
",f" & @CRLF & _
") CLOSE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")