const regex = /(^|\n)OPEN\(\n,*[^\n]*\n[^)]*\) *CLOSE/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\n)OPEN\\(\\n,*[^\\n]*\\n[^)]*\\) *CLOSE', 'gsm')
const str = `OPEN(
,a
,b
) CLOSE
OPEN(
c
) CLOSE
OPEN(
,d
,e
,f
) CLOSE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}