$re = '/(^|\n)OPEN\(\n,*[^\n]*\n[^)]*\) *CLOSE/sm';
$str = 'OPEN(
,a
,b
) CLOSE
OPEN(
c
) CLOSE
OPEN(
,d
,e
,f
) CLOSE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);