package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)(^|\n)OPEN\(\n,*[^\n]*\n[^)]*\) *CLOSE`)
var str = `OPEN(
,a
,b
) CLOSE
OPEN(
c
) CLOSE
OPEN(
,d
,e
,f
) CLOSE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}