import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\n)OPEN\\(\\n,*[^\\n]*\\n[^)]*\\) *CLOSE";
final String string = "OPEN(\n"
+ ",a\n"
+ ",b\n"
+ ") CLOSE\n"
+ "OPEN(\n"
+ "c\n"
+ ") CLOSE\n"
+ "OPEN(\n"
+ ",d\n"
+ ",e\n"
+ ",f\n"
+ ") CLOSE";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}