#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b((.*)user(.*)?)\b=(.*)"
Local $sString = "POSTGRES_U=)dadas'" & @CRLF & _
"postgres_u=afdsladfan" & @CRLF & _
"" & @CRLF & _
"POSTGRESU=ddadffdasf" & @CRLF & _
"postgresu=fsdaf;saf" & @CRLF & _
"" & @CRLF & _
"USER_POSTGRES=sm,df" & @CRLF & _
"POSTGRES_USER=dasdaa" & @CRLF & _
"user_postgres=dad$%lda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")