import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b((.*)user(.*)?)\\b=(.*)";
final String string = "POSTGRES_U=)dadas'\n"
+ "postgres_u=afdsladfan\n\n"
+ "POSTGRESU=ddadffdasf\n"
+ "postgresu=fsdaf;saf\n\n"
+ "USER_POSTGRES=sm,df\n"
+ "POSTGRES_USER=dasdaa\n"
+ "user_postgres=dad$%lda";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}