// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((.*)user(.*)?)\b=(.*)").unwrap();
let string = "POSTGRES_U=)dadas'
postgres_u=afdsladfan
POSTGRESU=ddadffdasf
postgresu=fsdaf;saf
USER_POSTGRES=sm,df
POSTGRES_USER=dasdaa
user_postgres=dad$%lda";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}