const regex = new RegExp('(?i)\\b((.*)user(.*)?)\\b=(.*)', '')
const str = `POSTGRES_U=)dadas'
postgres_u=afdsladfan
POSTGRESU=ddadffdasf
postgresu=fsdaf;saf
USER_POSTGRES=sm,df
POSTGRES_USER=dasdaa
user_postgres=dad\$%lda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}