$re = '/(?i)\b((.*)user(.*)?)\b=(.*)/';
$str = 'POSTGRES_U=)dadas\'
postgres_u=afdsladfan
POSTGRESU=ddadffdasf
postgresu=fsdaf;saf
USER_POSTGRES=sm,df
POSTGRES_USER=dasdaa
user_postgres=dad$%lda';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);