# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\([^|)]+\|[^)]+\) *\+ ?| \+? *\([^|)]+\|[^)]+\)//gm;t' <<< "y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g
y~1+a+(b|c)+(d^2)+e+ (1|f)+g
(b | c) + y ~ 1 + a + (d^2) + e + (1 | f) + g
y ~ 1 + a + (d^2) + e + (1 | f) + g + (b | c)
(h|i) + y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g +(j+k| m)"