import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\([^|)]+\\|[^)]+\\) *\\+ ?| \\+? *\\([^|)]+\\|[^)]+\\)";
final String string = "y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g\n"
+ "y~1+a+(b|c)+(d^2)+e+ (1|f)+g\n"
+ "(b | c) + y ~ 1 + a + (d^2) + e + (1 | f) + g\n"
+ "y ~ 1 + a + (d^2) + e + (1 | f) + g + (b | c) \n"
+ "(h|i) + y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g +(j+k| m)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}