import Foundation
let pattern = #"^\([^|)]+\|[^)]+\) *\+ ?| \+? *\([^|)]+\|[^)]+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g
y~1+a+(b|c)+(d^2)+e+ (1|f)+g
(b | c) + y ~ 1 + a + (d^2) + e + (1 | f) + g
y ~ 1 + a + (d^2) + e + (1 | f) + g + (b | c)
(h|i) + y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g +(j+k| m)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)