$re = '/^\([^|)]+\|[^)]+\) *\+ ?| \+? *\([^|)]+\|[^)]+\)/m';
$str = 'y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g
y~1+a+(b|c)+(d^2)+e+ (1|f)+g
(b | c) + y ~ 1 + a + (d^2) + e + (1 | f) + g
y ~ 1 + a + (d^2) + e + (1 | f) + g + (b | c)
(h|i) + y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g +(j+k| m)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;