package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)THttpServer:\W*(\w+)`)
var str = `23:25:04.805: INFO: THttpServer: transportTCPChanged(state: DISCONNECTED 2)
23:25:13.120: INFO: THttpServer: transportUDPOpened(state: Port 54)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}