import re
regex = re.compile(r"THttpServer:\W*(\w+)", flags=re.MULTILINE)
test_str = ("23:25:04.805: INFO: THttpServer: transportTCPChanged(state: DISCONNECTED 2)\n"
"23:25:13.120: INFO: THttpServer: transportUDPOpened(state: Port 54)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")