re = /THttpServer:\W*(\w+)/m
str = '23:25:04.805: INFO: THttpServer: transportTCPChanged(state: DISCONNECTED 2)
23:25:13.120: INFO: THttpServer: transportUDPOpened(state: Port 54)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end