package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<s\s?c\s?r\s?i\s?p\s?t\s?>.*<\/s\s?c\s?r\s?i\s?p\s?t\s?>`)
var str = `<script>var a = 5;</script>
<s c r i p t>var a = 5;</s c r i p t>
<SCRIPT>var a = 5;</SCRIPT>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}