re = /<s\s?c\s?r\s?i\s?p\s?t\s?>.*<\/s\s?c\s?r\s?i\s?p\s?t\s?>/mi
str = '<script>var a = 5;</script>
<s c r i p t>var a = 5;</s c r i p t>
<SCRIPT>var a = 5;</SCRIPT>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end