use strict;
my $str = '<script>var a = 5;</script>
<s c r i p t>var a = 5;</s c r i p t>
<SCRIPT>var a = 5;</SCRIPT>';
my $regex = qr/<s\s?c\s?r\s?i\s?p\s?t\s?>.*<\/s\s?c\s?r\s?i\s?p\s?t\s?>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}