$re = '/<s\s?c\s?r\s?i\s?p\s?t\s?>.*<\/s\s?c\s?r\s?i\s?p\s?t\s?>/mi';
$str = '<script>var a = 5;</script>
<s c r i p t>var a = 5;</s c r i p t>
<SCRIPT>var a = 5;</SCRIPT>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);