const regex = /<s\s?c\s?r\s?i\s?p\s?t\s?>.*<\/s\s?c\s?r\s?i\s?p\s?t\s?>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<s\\s?c\\s?r\\s?i\\s?p\\s?t\\s?>.*<\\\/s\\s?c\\s?r\\s?i\\s?p\\s?t\\s?>', 'gmi')
const str = `<script>var a = 5;</script>
<s c r i p t>var a = 5;</s c r i p t>
<SCRIPT>var a = 5;</SCRIPT>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}