#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(0|1000|[1-9]\d{0,2})(?:\.\d{1,2})?$"
Local $sString = "001" & @CRLF & _
"01" & @CRLF & _
"-0" & @CRLF & _
"0" & @CRLF & _
"-1" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"-10" & @CRLF & _
"-1000" & @CRLF & _
"-999.99" & @CRLF & _
"0001" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"10000" & @CRLF & _
"-1000" & @CRLF & _
"0.001" & @CRLF & _
"0.01" & @CRLF & _
"0.1" & @CRLF & _
"0032" & @CRLF & _
"1.2" & @CRLF & _
"0.2" & @CRLF & _
"-0.2" & @CRLF & _
"123" & @CRLF & _
"100" & @CRLF & _
"199" & @CRLF & _
"233" & @CRLF & _
"459" & @CRLF & _
"999" & @CRLF & _
"888" & @CRLF & _
"-999" & @CRLF & _
"-888" & @CRLF & _
"-123.21" & @CRLF & _
"-021.32" & @CRLF & _
"9999" & @CRLF & _
"-1.010" & @CRLF & _
"01.32" & @CRLF & _
"99.99" & @CRLF & _
"0" & @CRLF & _
"-1.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")